Blog

Noticias

Lanzamiento de Psycopg 2.9

¡Ha sido lanzado Psycopg 2.9!

Se trata de una versión relativamente pequeña en comparación con las anteriores. Aun así, la creación de los paquetes ha supuesto un gran esfuerzo. Debido al reducido soporte que ofrece ahora el sistema CI utilizado anteriormente para los proyectos de software libre, se decidió trasladar la compilación de los paquetes a GitHub Actions.

Además, el empaquetado se ha vuelto más complejo debido a la evolución de los estándares de empaquetado de Python y a la necesidad de soportar múltiples arquitecturas (Intel, ARM, PPC…).

Mantener un proyecto como Psycopg requiere mucho esfuerzo. Por esta razón, estamos muy agradecidos a todos nuestros patrocinadores que hacen posible el mantenimiento y desarrollo de Psycopg. ¡Muchas gracias! <3

Novedades en psycopg 2.9

  • with connection permite iniciar transacciones también en modo autocommit (ticket #941).
  • Las zonas horarias con fracciones de minutos están soportadas en Python 3.7 y versiones posteriores (ticket #1272).
  • Permite omitir nombres de tablas y columnas en copy_from() y copy_to().
  • Las excepciones de conexión con sqlstate ’08XXX’ han sido reclasificadas como OperationalError (una subclase del anterior DatabaseError) (ticket #1148).
  • Se han incluido los directorios de libpq para solucionar los problemas de compilación en MacOS (ticket #1200).

Otros cambios:

  • Se ha eliminado el soporte para Python 2.7, 3.4, 3.5 (ticket #1198, ticket #1000, ticket #1197).
  • Se ha eliminado el soporte para mx.DateTime.
  • Uso por defecto de objetos datetime.timezone, en lugar de FixedOffsetTimezone, en los objetos datetime.
  • El módulo psycopg2.tz es obsoleto y desaparecerá en la próxima versión principal.
  • Proporciona paquetes Wheels PEP 599 (etiqueta manylinux2014) para plataformas i686 y x86_64.
  • Proporciona paquetes Wheels PEP 599 (etiqueta manylinux_2_24) para plataformas aarch64 y ppc64le.
  • Paquete Wheel compilado para OpenSSL 1.1.1k y PostgreSQL 13.3.
  • Sistema de compilación de paquetes binarios para Linux y MacOS trasladado a GitHub Actions.

Psycopg es el adaptador más popular de PostgreSQL para el lenguaje de programación Python. En su núcleo implementa integralmente las especificaciones de Python DB API 2.0. Varias extensiones permiten el acceso a muchas de las características ofrecidas por PostgreSQL.

Haz clic aquí para leer la noticia original en inglés en la página web oficial de PostgreSQL.

Leave your thought here