Blog

Noticias

¡HypoPG 1.2 ya está disponible!

HypoPG


HypoPG es una extensión de PostgreSQL que añade soporte para los índices hipotéticos.

Ha sido lanzada la versión 1.2, que presenta los siguientes cambios:

Nuevas características:

  • Permite a hypopg funcionar en servidores standby usando un nuevo generador de OIDs «falsos», que utiliza OIDs presentes en el rango FirstBootstrapObjectId / FirstNormalObjectId en lugar de OIDs reales. De ser necesario, gracias a la nueva opción de configuración hypopg.use_real_oids, es posible seguir empleando el funcionamiento anterior.

Corrección de errores

  • Comprueba si los métodos de acceso admiten una cláusula INCLUDE para evitar la creación de índices hipotéticos no válidos.
  • Visualización de los índices hipotéticos en la tabla eliminada en hypopg_list_indexes.

Varios

  • Cambio en hypopg_list_indexes() para visualizar hypopg_list_indexes.
  • Varias mejoras en la documentación.

Enlaces


Para más información sobre esta versión o la extensión, consulta la documentación oficial.

Haz clic aquí para leer la noticia original en inglés en la página web oficial de PostgreSQL.

 

Leave your thought here