Blog

Noticias

Disponible la nueva herramienta pg_validate_extupgrade

Saludos,

Me complace anunciar el lanzamiento de pg_validate_extugprade, versión 1.0.0 beta.

Para aquellos que desarrollen extensiones de PostgreSQL y proporcionen scripts de instalación y actualización, pg_validate_extugprade les ayudará a validar sus scripts. Se trata de una nueva herramienta de línea de comandos que verificará que la instalación de una extensión en la versión X y su actualización a la versión Y cree exactamente los mismos objetos como si se instalara la extensión directamente en la versión Y. Además, en caso de encontrar algún problema, enumerará todas las diferencias.

Esta es una herramienta de código abierto, escrita en Rust, bajo licencia GPL3. Es compatible con las versiones 9.2 a 14 de PostgreSQL. Para más detalles y ejemplos de salida, pueden consultar el README del proyecto así como el bug tracker si tienen algún problema.

Cómo usarlo
USAGE:
    pg_validate_extupgrade [OPTIONS] --extname  --from  --to 

FLAGS:
    --help             Prints help information
    -V, --version      Prints version information

OPTIONS:
    -d, --dbname       database name
    -e, --extname      extension to test
        --from         initial version of the extension
    -h, --host         database server host or socket directory
    -p, --port         database server port
        --to           upgraded version of the extension
    -U, --user         database user name
Haz clic aquí para leer la noticia original en inglés en la página web oficial de PostgreSQL.

Leave your thought here